Icontem

WordPress needs to update its PHP code base

Recommend this page to a friend!

      JS Classes blog  >  Is Wordpress Switchin...  >  All threads  >  WordPress needs to update its PHP...  >  (Un) Subscribe thread alerts  
Subject:WordPress needs to update its PHP...
Summary:WordPress should use modern object oriented design patterns,PHP7
Messages:2
Author:Nadir Latif
Date:2015-12-12 02:31:38
Update:2016-03-07 18:50:11
 

  1. WordPress needs to update its PHP...   Reply   Report abuse  
Nadir Latif - 2015-12-12 03:07:09
I think WordPress needs to updates its code so its based on objects and not simple procedures.

WordPress was created 12 years ago and its code structure does not seem to have changed since then. As a result WordPress code is insecure and difficult to maintain.

I would suggest updating the WordPress core so its based on modern object oriented design patterns and the latest version of PHP

  2. Re: WordPress needs to update its PHP...   Reply   Report abuse  
Manuel Lemos - 2016-03-07 18:50:11 - In reply to message 1 from Nadir Latif
The problem is that all plugins rely on those procedural functions of WordPress. That is why it did not change in all these years.

Part of WordPress uses OOP but that is a part that does not affect plugins.